Tuesday 26 May 2015

Installing Wireshark with OpenFlow dissector on Ubuntu


  1. sudo apt-get -y remove wireshark
  2. sudo apt-get -y install libgtk-3-dev libqt4-dev flex bison
  3. wget http://www.wireshark.org/download/src/wireshark-1.12.5.tar.bz2 (At the time of installation latest version was 1.12.5. If you unable to do this step, then see this link https://www.wireshark.org/download/src/ for latest version)
  4.  tar xvfj wireshark-1.12.5.tar.bz2
  5. cd wireshark-1.12.5
  6. ./configure
  7. make -j4
  8. sudo make install
  9. cd ..
  10.  sudo sh -c "echo '/usr/local/lib' >> /etc/ld.so.conf"
  11. sudo ldconfig
  12.  Now start wireshark.
  13. sudo wireshark &
  14. To see OpenFlow packets write "openflow_v1" in the filter box.



References:


  1. http://sdnhub.org/forums/topic/wireshark-dissectore-fro-of-now-running-in-new-vm/
  2. http://askubuntu.com/questions/279853/permission-denied-error-when-editing-etc-ld-so-conf
  3. https://www.wireshark.org/download/src/

Friday 1 May 2015

Using D-ITG Traffic Generator in Mininet


  1.   Login into Mininet VM.
  2.   $ sudo apt-get install unzip
  3.  $ sudo apt-get install g++
  4.  $ wget   http://traffic.comics.unina.it/software/ITG/codice/D-ITG-2.8.1-r1023-src.zip
  5.   $ unzip  D-ITG-2.8.1-r1023-src.zip
  6.  $ cd  D-ITG-2.8.1-r1023/src
  7.   $ make

Once done, the binaries will be copied into the ”D-ITG-2.8.1-r2058M/bin” directory.

Demo Tutorial:



  1. Download and install Xming X Server for Windows (http://sourceforge.net/projects/xming/).
  2. Login into Mininet VM via PuTTY with X11 forwarding option selected.
  3. Login into Mininet (this session is for controller setup).
  4. $ cd  ~/pox
  5. $ ./pox.py forwarding.l2_learning
  6. Now run these commands into the first PuTTY session.
  7. $ cd ~
  8. $ sudo mn --controller=remote,ip=127.0.0.1,port=6633 
  9. $ xterm h1
  10. $ xterm h2 
  11. Now in the xterm window of h2, run these commands.
  12. $ cd D-ITG-2.8.1-r1023/bin
  13. $ ./ITGRecv 
  14. Now in the xterm of h1, run these commands.
  15. $ cd D-ITG-2.8.1-r1023/bin
  16. $ ./ITGSend –T UDP  –a 10.0.0.2 –c 100 –C 10 –t 15000 -l sender.log –x receiver.log 
  17. Now to analyze the logs, run these command.
  18. Run this in the xterm of h1.
  19. $ ./ITGDec sender.log

  20. Similarly run this on h2.
  21. $ ./ITGDec receiver.log 
References:
  1. mininet.org/walkthrough/
  2. traffic.comics.unina.it/software/ITG/manual/



Wednesday 3 December 2014

"Enabling OpenFlow v1.0 on Mikrotik RouterBoard 750GL: A Tutorial", ANDASH Report, 2014.

We have made a tutorial to make Mikrotik RouterBoard 750GL Openflow enabled.
What this tutorial contain:
-Installation procedure of OpenWRT on RouterBoard GL750
-Installation procedure of Openflow v1.0 on RouterBoard GL750
-Installation of POX/Floodlight Controller
-Testing of OpenFlow enabled Network
This tutorial can be downloaded from the following link:
http://andash.seecs.nust.edu.pk/andash_publications/SDN.pdf

Sunday 28 September 2014

Installation of POX controller

Installation of POX controller:

·         $ sudo –s        (login as root)
·         $ cd Desktop
·         $ git clone http://github.com/noxrepo/pox
·         $ cd pox
To start POX controller
·         $ ./pox.py openflow.of_01  --port=<port no>

You will see this after this step

Friday 19 September 2014

Installation of Openflow on RouterOS (RouterBoard 750GL)

  1. 1.    RouterOS 6.17 version has the compatibility for the openflow. So first step is to upgrade your RouterOS to latest version (i.e currently latest version is 6.17).

  2. Upgrade process:
  • First step - visit http://www.mikrotik.com/download and head to the download page, there choose the type of system you have the RouterOS installed on.
  • Download the the upgrade package and the All packages (In All packages folder you will find the openflow package), it will include all the functionality of RouterOS:


  •   Now install Winbox from the http://www.mikrotik.com/download.
  •  Open winbox and login into the router using (IP: 192.168.88.1 username=admin passward=blank)
  •  Select the downloaded file (upgrade package file) with your mouse, and drag it to the Files menu. If there are some files already present, make sure to put the package in the root menu, not inside the hotspot folder.

  • After it finishes - REBOOT and that's all! The New version number will be seen in the Winbox Title and in the Packages menu.
  • To reboot the router click on the New Terminal on the left and type system reboot.
  •   After the reboot, your router will be up to date, you can check it in this menu by typing  /system package print in the New Terminal window.

  • If your router did not upgrade correctly, make sure you check the log by typing /log print without-paging.
  •  At this point your RouterBoard is now up gradated to the latest version and ready to install the openflow on it.

Openflow Installation:

  • First extract the All packages folder that we had already downloaded. This folder contain the openflow package.
  • Now again log in to router using winbox and go to the Files and drag there the openflow package.
  •   Now again reboot the router and to see the installed packages by typing /system package print. You will see that openflow package is listed there.
Configuration:
  • RouterOS supports multiple OpenFlow switch instances, each of which can have separate controller(s) and sets of ports.

  • Switch instance can be added using command.
  •     [admin@MikroTik] > /openflow add name=ofswitch1 controllers=10.0.0.18
  • Switch ports can be added using command:
  • [admin@MikroTik] > /openflow port add switch=ofswitch1 interface=ether2
  • [admin@MikroTik] > /openflow port add switch=ofswitch1 interface=ether2